Logo Search packages:      
Sourcecode: aap version File versions

def aap-1.090::DoBuild::Update::outdated (   self,
  target 
)

Return TRUE if we already know that updating is required.
   This doesn't handle a source being newer than the target.

Definition at line 189 of file DoBuild.py.

00189                               :
        """Return TRUE if we already know that updating is required.
           This doesn't handle a source being newer than the target."""
        return (self.forced
                or self.time
                or self.source
                or (target.attributes.get("virtual")
                    and not target.attributes.get("remember")))

    def set_buildcheck(self, recdict, str, target, level):


Generated by  Doxygen 1.6.0   Back to index